Sunday, May 12, 2013

" java.lang.UnsatisfiedLinkError" When Run Oracle EBS

Exception in thread "main" java.lang.UnsatisfiedLinkError: /u01/media/StageR12/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/lib/i386/xawt/libmawt.so: libXi.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.load0(Unknown Source)
at java.lang.System.load(Unknown Source)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at sun.security.action.LoadLibraryAction.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)
at sun.awt.DebugHelper.(Unknown Source)
at java.awt.Component.(Unknown Source

This error appear while trying to  ./rapidwiz in Oracle EBS , and it's regarding to Wrong packager version

First you need to remove the old package using :

rpm -e --nodeps
Install the required package from the below link :

Package libXi 32bit Here
Package libXi 64bit Here




Re Run the Installer again

Enjoy

Thank you
Osama Mustafa

2 comments:

  1. Thank you for this Osama,

    I'm getting this same error but when I try to remove the old package, I'm getting "rpm -nodeps: unknown option"

    I don't understand what I'm actually removing here.

    ReplyDelete
  2. 1. copy repo from https://public-yum.oracle.com/public-yum-ol6.repo to /etc/yum.repos.d/

    2. enable addons channel in .repo file.

    3. yum install oracle-ebs-server-R12-preinstall -y
    above steps will cover dependencies and let you install EBS.

    ReplyDelete