Saturday, January 23, 2016

JspCompile.pl Hangs after upgrading to EBS R12.2.4 Any idea ?

Let me tell you what is going on here , maybe you have some idea that can help, the scenario like the following :-

I installed Oracle E-business suite on Linux 64bit Operating system version 6.7 without any issue and the EBS version was R12.2.0 and the default database version which is 11.2.0.3.

But i choose to upgrade to EBS R12.2.4 and Oracle database 12c both done without any issues or even small error in the logs , auto config done successfully without any issue as well, the application started without any single error.

But when trying to access to the EBS application Link

I tried to compile the JSP but :-

[oracle@ammebs scripts]$ tail -f /u01/oracle/tbdlamm/fs_ne/EBSapps/log/adop/16/apply_20160114_142741/20518047/log/u20518047.log
enumerating jsps...7829
updating dependency...6473
parsing jsp...6473
writing deplist...7829
initializing compilation:
eliminating children...5954 (-1875)
searching uncompiled...5682 (2253 were stale)
translating and compiling:
searching untranslated...5622 (3369 were stale)
translating jsps... 85% complete: 4800/5622 ETA: 53s
translating jsps...5622/5622 in 7m31s
compiling jsps... 


The Logs shows only this error :-

[213441] !!SEVERE WARNING!! TIMEOUT[600 seconds] EXPIRED DURING COMPILATION  


I increased the apache timeout in the context file for nothing .

When access the EBS Application Link :-

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address. 
I opened SR and now it's 45  days without any solution !!!!

Any idea

Thank you guys :)
Osama

6 comments:


  1. Hi,

    We are facing exactly the same issue here :-(

    Did you solve your problem ? What was the answer to the SR?

    Thanks for your help.

    Pierre

    ReplyDelete
    Replies
    1. Actually after working for more than 1 month with Oracle Support to solve this issue i worked in parallel to create new environment but this time using Yum and it's worked without any issue, which mean this happened because some of the pre-requisites missing.

      Delete
  2. I am also facing issue, how did you solve the issue

    ReplyDelete
    Replies
    1. This error related to missing in prerequisites i prefer to recreate the machine and read oracle documentation very carefully

      Delete
  3. When I had the problem last year, I was on a Red Hat 6.7 environment. I reinstalled it on RHEL 6.6 and problem disappeared.

    ReplyDelete
    Replies
    1. Exactly this error related to prerequisites

      Delete